NHSMail service experiencing some issues
Incident Report for eConsult Health Limited
Resolved
NHS mail have confirmed the backlog has been cleared due to the delayed delivery issue they faced earlier.

If you have any queries please email practice.support@econsult.health
Posted Jun 21, 2022 - 18:01 BST
Monitoring
NHS mail have identified the issue is related to a Microsoft roll out for more information please see here - https://support.nhs.net/2022/06/inc29834135-nhsmail-delivery-delay-new/

We are getting confirmations of delivery for emails that have been deferred. We are continuing to monitor.

Any questions please contact the Operations Team on practice.support@econsult.health
Posted Jun 21, 2022 - 13:08 BST
Identified
NHS mail have confirmed there is an issue, we are awaiting further information. For more information direct for NHSD see here:https://support.nhs.net/service-status/#
Posted Jun 21, 2022 - 09:53 BST
Investigating
We are currently experiencing issues with NHS mail impacting practices receiving eConsults via email and also any activation emails.

We are investigating with NHS mail to understand the scale of issue and the impact.

If you have any queries or need support please email practice.support@econsult.health
Posted Jun 21, 2022 - 08:47 BST
This incident affected: eConsult online consultations and eConsult Toolbar.