Toolbar - Video and telephony error
Incident Report for eConsult Health Limited
Resolved
We have resolved this issue, it was related to a server error which has now been fixed. Thank you for your patience whilst we worked to fix this issue.

If you have any questions or are still facing issues please contact the Operations Team on practice.support@econsult.health
Posted May 10, 2022 - 14:20 BST
Investigating
A number of toolbar users are reporting issues accessing the video and telephony section of the eConsult Toolbar we are investigating this now.
Posted May 09, 2022 - 18:12 BST
This incident affected: Q health/ Q doctor video.