Problem accessing eConsult service
Incident Report for eConsult Health Limited
Resolved
eConsult have rolled back the release this morning and can confirm all areas of the eConsult platform are back up and running. Thank you for your patience this morning. For any queries please email practice.support@econsult.health or use the live chat via our website econsult.net
Posted Aug 05, 2022 - 09:30 BST
Investigating
We are currently investigating an issue caused by a production release this morning impacting customers and patients accessing eConsult. This includes patient submissions, PCM and activation screens. The error message reads "We are currently handling unprecedented demand". Thank you for your patience, we will continue to update the status page.

For any queries please email practice.support@econsult.health or use the live chat via our website econsult.net
Posted Aug 05, 2022 - 08:49 BST
This incident affected: eConsult online consultations.