NHSMail service experiencing some issues
Incident Report for eConsult Health Limited
Resolved
We can confirm this issue has been resolved. We are continuing to monitor and will be in touch tomorrow (20/6/22) with any practices that were impacted.
Apologies for any inconvenience and please email practice.support@econsult.health if you have any questions.
Posted Jun 19, 2022 - 23:01 BST
Investigating
We are currently experiencing some issues with NHS mail impacting practices receiving eConsults via email. We are investigating with NHSD to understand the scale of issue and the impact.
Posted Jun 19, 2022 - 22:24 BST
This incident affected: eConsult online consultations.