Back to overview
Downtime
Unable to load Smart Inbox messages
Apr 29, 2026 at 11:20am UTC
Affected services
Smart Inbox
Resolved
Apr 29, 2026 at 1:00pm UTC
The earlier reported issue has now been resolved following the rollout of the fix. Please restart your Smart Inbox and reach out to support if you continue to have issues.
Affected services
Updated
Apr 29, 2026 at 12:49pm UTC
The root cause has been identified and a fix is now being applied and rolled out.
Affected services
Created
Apr 29, 2026 at 11:20am UTC
We are aware of an issue affecting the loading of Smart Inbox messages.
Our engineering team are currently investigating and will have further updates shortly.
Affected services