Back to overview
Degraded

Unable to login to eConsult in a browser using NHSMail

May 21, 2026 at 7:49am UTC
Affected services
eConsult
Smart Inbox

Resolved
May 21, 2026 at 10:02am UTC

The earlier reported issue with logging in via NHSMail has now been identified and resolved.

If you continue to experience issues, please reach out to support.

Created
May 21, 2026 at 7:49am UTC

We are aware of an issue with accessing eConsult via a browser when using NHSMail login such as eLite or https://settings.econsult.health.

Users are advised to login with the 'Log in with another email' option. If you are not sure what your password is, please use the on-screen options to reset your password.

Our Engineering team are currently investigating the root cause and working on a fix.